CVE-2026-22853: FreeRDP RDPEAR Heap Overflow Fixed in 3.20.1
CVE-2026-22853 is a critical heap buffer overflow (CVSS 9.8) in the FreeRDP RDPEAR array reader before 3.20.1. Upgrade to FreeRDP 3.20.1 or later.
Deep dives, practical guides, and incident analyses from engineers who build Safeguard. No fluff, no vendor FUD — just what you need to ship secure software.
CVE-2026-22853 is a critical heap buffer overflow (CVSS 9.8) in the FreeRDP RDPEAR array reader before 3.20.1. Upgrade to FreeRDP 3.20.1 or later.
CVE-2026-22852 is a critical heap buffer overflow (CVSS 9.8) in the FreeRDP client audio input handler before 3.20.1. Upgrade to FreeRDP 3.20.1.
CVE-2026-22807 is a high severity code execution flaw (CVSS 8.8) in vLLM 0.10.1 to before 0.14.0, run at model load. Upgrade vLLM to 0.14.0 or later.
CVE-2026-22785 is a critical code injection (CVSS 9.8) in orval before 7.18.0, via the OpenAPI summary field. Upgrade orval to 7.18.0 or later.
CVE-2026-22781 is a critical OS command injection (CVSS 9.8) in TinyWeb before 1.98 through CGI queries. Upgrade to 1.98 or remove the CGI scripts.
CVE-2026-22770 is a medium flaw (CVSS 6.5) in ImageMagick BilateralBlurImage before 7.1.2-13. Update to 7.1.2-13 or later and check your distro package.
CVE-2026-22720 is a high severity stored XSS (CVSS 8.0) in VMware Aria Operations. Apply the patches in the response matrix of VMSA-2026-0001.
CVE-2026-22709 is a critical sandbox escape (CVSS 9.8) in vm2 before 3.10.2 through Promise callbacks. Upgrade vm2 to 3.10.2 or replace the sandbox.
CVE-2026-22708 is a critical Cursor flaw (CVSS 9.8) where shell built-ins skip the Auto-Run allowlist and enable prompt injection. Update to Cursor 2.3.
Weekly insights on software supply chain security, delivered to your inbox.
Your first fix PR is minutes away.
No sales call required, even your agent can complete the purchase over MCP.