CVE-2026-56400: Open WebUI CORS Misconfiguration Leads to RCE
CVE-2026-56400 is a high severity CORS flaw in Open WebUI before 0.3.14 that can let a malicious site run code on the server. Upgrade to 0.3.33 or later.
Deep dives, practical guides, and incident analyses from engineers who build Safeguard. No fluff, no vendor FUD — just what you need to ship secure software.
CVE-2026-56400 is a high severity CORS flaw in Open WebUI before 0.3.14 that can let a malicious site run code on the server. Upgrade to 0.3.33 or later.
CVE-2026-56398 is a high severity stored XSS in Open WebUI through OAuth profile pictures before 0.9.5. Upgrade to 0.9.5 or later and set security headers.
CVE-2026-5562 is a code injection flaw in Kafka UI through 0.7.2 at the smart filters test endpoint, with a public exploit. No fix is listed; restrict access.
CVE-2026-55471 is an XXE flaw in HAPI FHIR core before 6.9.10 through the saxonTransform helpers. Upgrade to 6.9.10 and check where you transform XML.
CVE-2026-55455 is an SSRF filter bypass in Appsmith before 2.1 that lets a signed-in user reach loopback services in the container. Upgrade to 2.1.
CVE-2026-5526 is an access control flaw in the Tenda 4G03 Pro httpd, remotely reachable, with a public exploit. No fix is listed, so limit exposure now.
CVE-2026-55203 is an integer overflow in the HAProxy FastCGI multiplexer through 3.4.0 that can desynchronize framing. Apply the fix from commit 5985276.
CVE-2026-55194 is a heap overflow in FreeRDP clients below 3.27.0 that use an RD Gateway, triggered by a malicious gateway. Upgrade to 3.27.0.
CVE-2026-55191 is a heap overflow in FreeRDP clients below 3.27.0 when connecting to a malicious RDP server. Upgrade to 3.27.0 and avoid untrusted servers.
Weekly insights on software supply chain security, delivered to your inbox.
Your first fix PR is minutes away.
No sales call required, even your agent can complete the purchase over MCP.