CVE-2023-51409 is an unrestricted file upload flaw in the AI Engine ChatGPT Chatbot plugin by Jordy Meow, rated Critical (10.0). It affects versions up to and including 1.9.98. Update to 1.9.99 or later.
What's affected
The NVD record names AI Engine ChatGPT Chatbot by Jordy Meow and lists versions up to and including 1.9.98. Patchstack lists the required privilege as unauthenticated and rates its own priority High.
| Item | Detail |
|---|---|
| Product | AI Engine ChatGPT Chatbot (WordPress plugin) |
| Affected | versions up to and including 1.9.98 |
| Fixed | 1.9.99 or later |
| CVSS | 10.0 (Critical), vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H |
| Weakness | CWE-434 (Unrestricted Upload of File with Dangerous Type) |
| Published | 2024-04-12 |
The record's CISA Known Exploited Vulnerabilities flag is false for this CVE.
How to check if you're exposed
If you manage the site with WP-CLI, list the installed version and whether an update is waiting:
wp plugin list --fields=name,status,version,update_version | grep ai-engine
You can also open Plugins in the WordPress dashboard and read the version under the plugin name. Compare it with the affected range above. If you run many sites, export an inventory of plugins and versions from each one and compare them in one pass. The free scanner at gold.safeguard.sh/scan can check a dependency manifest in the browser, and the Gold directory lists known issues by component.
Also check staging copies and sites that were cloned from older backups. Inactive plugins still sit on disk and some of them still expose files, so remove plugins you no longer use rather than only deactivating them.
What to do now
- Update AI Engine ChatGPT Chatbot to 1.9.99 or later. Back up the site first if you have not already.
- Run the update on staging first if the plugin is business critical, then roll it out to production.
- Re-run the WP-CLI check above on every site you manage and confirm no copy remains in the affected range.
- Remove the plugin if you no longer need it, instead of leaving it deactivated.
- Review administrator accounts and recent changes on any site that ran an affected version while exposed to the internet.
Why it matters
The record classifies this as CWE-434 (Unrestricted Upload of File with Dangerous Type).
Unrestricted upload bugs let a request place a file on the server without enough checks on its type or content. On a web server that runs PHP, a file with an executable type in a reachable folder can lead to code execution, which is why the base score reaches the maximum of 10.0 with a changed scope.
Defenses are layered. Fix the plugin, restrict what file types the web server will execute from upload folders, and keep a record of unexpected new files in the uploads directory.
Source conflict on exploitation: the record shows the CISA KEV flag as false, while the Patchstack page carries a Known to be exploited label for this entry. Both are reported here. Treat the issue as urgent either way. The record also lists a public GitHub repository among its references. It is not linked or described here.
Try it yourself
Click through it at your own pace, or open it full screen.
Quick check
Is a login required?
Patchstack lists the required privilege as unauthenticated, so no login is needed. Update immediately and check your uploads folder for files you do not recognize.
How do I know which version is fixed?
Use the version stated under What is affected, and confirm it against the vendor changelog or advisory linked in Sources before you close the ticket.
Sources
- NVD record data for CVE-2023-51409 via Safeguard Gold
- Patchstack advisory (fetched)
Last reviewed: 19 October 2026.