CVE-2023-51408 is an information exposure issue where sensitive data ends up in a log file that can be read without authorization in the WP Optin Wheel plugin by StudioWombat, rated Medium (5.3). It affects versions up to and including 1.4.3. Update to 1.4.4 or later.
What's affected
The NVD record names WP Optin Wheel by StudioWombat and lists versions up to and including 1.4.3. Patchstack lists the required privilege as unauthenticated.
| Item | Detail |
|---|---|
| Product | WP Optin Wheel (WordPress plugin) |
| Affected | versions up to and including 1.4.3 |
| Fixed | 1.4.4 or later |
| CVSS | 5.3 (Medium), vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N |
| Weakness | CWE-532 (Insertion of Sensitive Information into Log File) |
| Published | 2024-01-08 |
The record's CISA Known Exploited Vulnerabilities flag is false for this CVE.
How to check if you're exposed
If you manage the site with WP-CLI, list the installed version and whether an update is waiting:
wp plugin list --fields=name,status,version,update_version | grep wp-optin-wheel
You can also open Plugins in the WordPress dashboard and read the version under the plugin name. Compare it with the affected range above. If you run many sites, export an inventory of plugins and versions from each one and compare them in one pass. The free scanner at gold.safeguard.sh/scan can check a dependency manifest in the browser, and the Gold directory lists known issues by component.
Also check staging copies and sites that were cloned from older backups. Inactive plugins still sit on disk and some of them still expose files, so remove plugins you no longer use rather than only deactivating them.
What to do now
- Update WP Optin Wheel to 1.4.4 or later. Back up the site first if you have not already.
- Run the update on staging first if the plugin is business critical, then roll it out to production.
- Re-run the WP-CLI check above on every site you manage and confirm no copy remains in the affected range.
- Remove the plugin if you no longer need it, instead of leaving it deactivated.
- Review administrator accounts and recent changes on any site that ran an affected version while exposed to the internet.
Why it matters
The record classifies this as CWE-532 (Insertion of Sensitive Information into Log File).
Log files are written for the site owner, but they sit on the web server. If the log lives in a path that the web server will serve, and the file name is predictable, anyone can request it. Logs often hold request details, internal paths, error text and sometimes identifiers or tokens.
The impact here is limited to confidentiality, which is why the base score is medium. Still, leaked paths and identifiers help an attacker plan a second step, so the fix is worth applying promptly and old log files are worth removing.
Quick check
What should I do about log files that already exist?
Update the plugin first. Then look for old log files the plugin wrote, remove them from the web root, and consider whether anything sensitive in them needs rotating.
How do I know which version is fixed?
Use the version stated under What is affected, and confirm it against the vendor changelog or advisory linked in Sources before you close the ticket.
Sources
- NVD record data for CVE-2023-51408 via Safeguard Gold
- Patchstack advisory (fetched)
Last reviewed: 19 October 2026.