Safeguard
Vulnerability Analysis•

CVE-2023-51406: Medium Log Data Exposure in FastDup

CVE-2023-51406 is a medium log file data exposure in the FastDup WordPress plugin. Update to 2.1.8 or later. Check each site you manage now.

Safeguard Security Team
3 min read

CVE-2023-51406 is an information exposure issue where sensitive data ends up in a log file that can be read without authorization in the FastDup plugin by Ninja Team, rated Medium (5.3). It affects versions up to and including 2.1.7. Update to 2.1.8 or later.

What's affected

The NVD record names FastDup by Ninja Team and lists versions up to and including 2.1.7. Patchstack lists the required privilege as unauthenticated.

ItemDetail
ProductFastDup (WordPress plugin)
Affectedversions up to and including 2.1.7
Fixed2.1.8 or later
CVSS5.3 (Medium), vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
WeaknessCWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)
Published2024-01-08

The record's CISA Known Exploited Vulnerabilities flag is false for this CVE.

How to check if you're exposed

If you manage the site with WP-CLI, list the installed version and whether an update is waiting:

wp plugin list --fields=name,status,version,update_version | grep fastdup

You can also open Plugins in the WordPress dashboard and read the version under the plugin name. Compare it with the affected range above. If you run many sites, export an inventory of plugins and versions from each one and compare them in one pass. The free scanner at gold.safeguard.sh/scan can check a dependency manifest in the browser, and the Gold directory lists known issues by component.

Also check staging copies and sites that were cloned from older backups. Inactive plugins still sit on disk and some of them still expose files, so remove plugins you no longer use rather than only deactivating them.

What to do now

  1. Update FastDup to 2.1.8 or later. Back up the site first if you have not already.
  2. Run the update on staging first if the plugin is business critical, then roll it out to production.
  3. Re-run the WP-CLI check above on every site you manage and confirm no copy remains in the affected range.
  4. Remove the plugin if you no longer need it, instead of leaving it deactivated.
  5. Review administrator accounts and recent changes on any site that ran an affected version while exposed to the internet.

Why it matters

The record classifies this as CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor).

Log files are written for the site owner, but they sit on the web server. If the log lives in a path that the web server will serve, and the file name is predictable, anyone can request it. Logs often hold request details, internal paths, error text and sometimes identifiers or tokens.

The impact here is limited to confidentiality, which is why the base score is medium. Still, leaked paths and identifiers help an attacker plan a second step, so the fix is worth applying promptly and old log files are worth removing.

Quick check

What should I do about log files that already exist?

Update the plugin first. Then look for old log files the plugin wrote, remove them from the web root, and consider whether anything sensitive in them needs rotating.

How do I know which version is fixed?

Use the version stated under What is affected, and confirm it against the vendor changelog or advisory linked in Sources before you close the ticket.

Sources

Last reviewed: 19 October 2026.

Never miss an update

Weekly insights on software supply chain security, delivered to your inbox.

We email you a link to confirm, and only then add you to the list. Unsubscribe in one click. Privacy

Self-healing security runs on Safeguard.

Your first fix PR is minutes away.

No sales call required, even your agent can complete the purchase over MCP.