Safeguard
Vulnerability Analysis•

CVE-2023-51405: High Auth Flaw in BookingPress

CVE-2023-51405 is a high authentication flaw in the BookingPress WordPress plugin. Update to 1.0.75 or later. Check each site you manage now.

Safeguard Security Team
3 min read

CVE-2023-51405 is an authentication flaw that allows privilege escalation in the BookingPress plugin by Repute Infosystems, rated High (8.2). It affects versions up to and including 1.0.74. Update to 1.0.75 or later.

What's affected

The NVD record names BookingPress by Repute Infosystems and lists versions up to and including 1.0.74. Patchstack lists the required privilege as unauthenticated. The Patchstack page title for this entry describes it as booking price manipulation, which fits the record text about functionality not properly constrained by access controls.

ItemDetail
ProductBookingPress (WordPress plugin)
Affectedversions up to and including 1.0.74
Fixed1.0.75 or later
CVSS8.2 (High), vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:L
WeaknessCWE-287 (Improper Authentication), CWE-863 (Incorrect Authorization)
Published2024-04-24

The record's CISA Known Exploited Vulnerabilities flag is false for this CVE.

How to check if you're exposed

If you manage the site with WP-CLI, list the installed version and whether an update is waiting:

wp plugin list --fields=name,status,version,update_version | grep bookingpress-appointment-booking

You can also open Plugins in the WordPress dashboard and read the version under the plugin name. Compare it with the affected range above. If you run many sites, export an inventory of plugins and versions from each one and compare them in one pass. The free scanner at gold.safeguard.sh/scan can check a dependency manifest in the browser, and the Gold directory lists known issues by component.

Also check staging copies and sites that were cloned from older backups. Inactive plugins still sit on disk and some of them still expose files, so remove plugins you no longer use rather than only deactivating them.

What to do now

  1. Update BookingPress to 1.0.75 or later. Back up the site first if you have not already.
  2. Run the update on staging first if the plugin is business critical, then roll it out to production.
  3. Re-run the WP-CLI check above on every site you manage and confirm no copy remains in the affected range.
  4. Remove the plugin if you no longer need it, instead of leaving it deactivated.
  5. Review administrator accounts and recent changes on any site that ran an affected version while exposed to the internet.

Why it matters

The record classifies this as CWE-287 (Improper Authentication), CWE-863 (Incorrect Authorization).

Authentication bugs mean the application accepts a claim of identity without proving it. In plugin code this often shows up as a request handler that trusts a value sent by the client, such as an email address or an identifier, instead of checking a session or a secret.

When no login is needed to trigger the flaw, the attacker's cost drops to almost nothing and mass scanning becomes practical. Treat unauthenticated issues of this kind as patch first, investigate second.

Patchstack lists its own priority as Low, while the CVSS base score is 8.2 (High). Both are reported here.

Quick check

Is a login needed to reach the bug?

The Patchstack entry lists the required privilege as unauthenticated, which means no login is needed. Update before you investigate.

How do I know which version is fixed?

Use the version stated under What is affected, and confirm it against the vendor changelog or advisory linked in Sources before you close the ticket.

Sources

Last reviewed: 19 October 2026.

Never miss an update

Weekly insights on software supply chain security, delivered to your inbox.

We email you a link to confirm, and only then add you to the list. Unsubscribe in one click. Privacy

Self-healing security runs on Safeguard.

Your first fix PR is minutes away.

No sales call required, even your agent can complete the purchase over MCP.