CVE-2024-2452: High Integer Wraparound in Eclipse ThreadX NetX Duo
CVE-2024-2452 is an integer wraparound in Eclipse ThreadX NetX Duo before 6.4.0 that can cause heap overflow (CVSS 7.0). Upgrade to 6.4.0 or later.
Deep dives, practical guides, and incident analyses from engineers who build Safeguard. No fluff, no vendor FUD — just what you need to ship secure software.
CVE-2024-2452 is an integer wraparound in Eclipse ThreadX NetX Duo before 6.4.0 that can cause heap overflow (CVSS 7.0). Upgrade to 6.4.0 or later.
CVE-2024-2450 lets an authenticated Mattermost user take over accounts when switching to SAML (CVSS 8.8). Upgrade to 8.1.10, 9.2.6, 9.3.2 or 9.4.3.
CVE-2024-2443 is a GeoJSON settings command injection in GitHub Enterprise Server (NVD 9.1, GitHub says High). Upgrade to 3.8.17, 3.9.12, 3.10.9, 3.11.7 or 3.12.1.
CVE-2024-2434 is a high severity (8.5) path traversal in GitLab 16.9 to 16.11 that can cause DoS and restricted file read. Upgrade to 16.9.6, 16.10.4 or 16.11.1.
CVE-2024-2432 is a race condition privilege escalation in the Palo Alto Networks GlobalProtect app on Windows (NVD 4.5, vendor 5.2). Upgrade.
CVE-2024-2422 is an authenticated argument injection leading to command execution in LenelS2 NetBox 5.6.1 and earlier (CVSS 8.8). Upgrade to 5.6.2.
CVE-2024-2421 is an unauthenticated OS command injection in LenelS2 NetBox 5.6.1 and earlier (NVD 9.8, CISA 9.1). Upgrade to NetBox 5.6.2.
CVE-2024-2420 is a critical (9.8) hardcoded credential flaw in LenelS2 NetBox through 5.6.1 allowing authentication bypass. Upgrade to 5.6.2.
CVE-2024-2418 is a medium SQL injection in Best POS Management System 1.0 via the id argument in view_order.php. No fix is confirmed. Parameterize queries.
Weekly insights on software supply chain security, delivered to your inbox.
Your first fix PR is minutes away.
No sales call required, even your agent can complete the purchase over MCP.