CVE-2024-4889: High Code Injection in LiteLLM Secret Manager
CVE-2024-4889 is a high (7.2) code injection in BerriAI LiteLLM 1.34.6 when Google KMS is configured. Upgrade past 1.34.6 once the project confirms a fix.
Deep dives, practical guides, and incident analyses from engineers who build Safeguard. No fluff, no vendor FUD — just what you need to ship secure software.
CVE-2024-4889 is a high (7.2) code injection in BerriAI LiteLLM 1.34.6 when Google KMS is configured. Upgrade past 1.34.6 once the project confirms a fix.
CVE-2024-4888 is a high (8.1) arbitrary file deletion in BerriAI LiteLLM's audio transcriptions endpoint. Check the project for a fixed release and upgrade.
CVE-2024-4884 is a critical (9.8) unauthenticated RCE in Progress WhatsUp Gold before 2023.1.3, in CommunityController. Upgrade to 2023.1.3 or later.
CVE-2024-4883 is a critical (9.8) unauthenticated RCE in Progress WhatsUp Gold before 2023.1.3, via NmApi.exe. Upgrade to 2023.1.3 or later.
CVE-2024-4881 is a high (7.5) path traversal in parisneo/lollms on Windows. The record gives conflicting version data, so check the commit and upgrade.
CVE-2024-4872 is a critical (9.9) query validation flaw in Hitachi Energy MicroSCADA Pro/X SYS600 9.4. Read the vendor advisory for the fix and restrict credentials.
CVE-2024-4854 is a medium (6.4) denial of service in Wireshark dissectors. Upgrade to 4.2.5, 4.0.15 or 3.6.23 or later, and open untrusted captures with care.
CVE-2024-4851 is a high (7.7) server-side request forgery in Quivr 0.0.204. No fixed version is confirmed, so restrict the crawl endpoint and check the project.
CVE-2024-4835 is a high (8.0) cross-site scripting flaw in GitLab CE and EE. Upgrade to 16.10.6, 16.11.3 or 17.0.1, or later in your release line.
Weekly insights on software supply chain security, delivered to your inbox.
Your first fix PR is minutes away.
No sales call required, even your agent can complete the purchase over MCP.