CVE-2025-36222 is a high severity (CVSS 8.7) insecure default in IBM Fusion, Fusion HCI and Fusion HCI for watsonx, which could expose AMQ Streams without client authentication. IBM's fix is an upgrade to version 2.11.0.
What's affected
IBM's bulletin lists these ranges:
- IBM Fusion 2.2.0 through 2.10.1
- IBM Fusion HCI 2.2.0 through 2.10.0
- IBM Fusion HCI for watsonx 2.8.2 through 2.10.0
The weakness is an insecure default configuration. Per the record, AMQ Streams could be exposed without client authentication, which could let an attacker perform unauthorized actions. IBM's vector is network reachable, high complexity, no privileges, no user interaction, with scope changed. The record does not mark it as exploited in the wild, and it is not on the CISA Known Exploited Vulnerabilities list.
The same bulletin covers a long list of other CVEs in bundled components, so reading it is worthwhile even if you only track this one.
How to check if you're exposed
- Find your Fusion version in the product console or through the installed operator information.
- Compare it with the ranges above.
- Review your AMQ Streams and Kafka listener configuration in the Fusion environment. Look for listeners that do not require client authentication.
- Check which networks can reach those listeners. Fewer reachable networks means less exposure.
- For other components in the cluster, run an image scan. The free in-browser dependency scan at gold.safeguard.sh/scan and the Gold directory are a start.
What to do now
- Upgrade IBM Fusion to 2.11.0, IBM Fusion HCI to 2.11.0, or IBM Fusion HCI for watsonx to 2.11.0, following the README IBM links.
- After the upgrade, verify that AMQ Streams listeners require client authentication.
- Restrict network paths to the messaging listeners with network policies.
- Review messaging logs from before the upgrade for clients you do not recognise.
- Treat any topics that carry sensitive data as potentially read until you have reviewed access.
IBM lists no workarounds or mitigations, so the upgrade is the fix.
Why it matters
The class is CWE-1188, initialization of a resource with an insecure default. Nothing is broken in the code path itself. The product ships with a setting that is safe for a lab but unsafe in production, and many deployments keep defaults.
Message brokers sit between systems and often carry data nobody else sees. If a broker accepts clients without authentication, anyone who can reach it can read or write messages. That is why the scope is marked changed in IBM's vector.
Defaults are a policy decision. Review them as part of every platform upgrade.
Quick check
What is the fixed version?
IBM says to upgrade to Fusion, Fusion HCI or Fusion HCI for watsonx 2.11.0.
Why is an insecure default a vulnerability?
Because many deployments never change it, so the product is exposed as shipped.
Sources
Last reviewed: 18 October 2026.