CVE-2025-12762 is a critical remote code execution flaw (CVSS 9.1) in pgAdmin 4 up to version 9.9, when it runs in server mode and restores PLAIN-format dump files. The pgAdmin 9.10 release notes list the fix, so upgrade to 9.10 or later.
What's affected
The record says pgAdmin versions up to 9.9 are affected, and only when pgAdmin runs in server mode and performs restores from PLAIN-format SQL dump files. The upstream issue lists the OS, browser and package type as all, so the packaging does not change the exposure. Desktop mode is not the scenario described.
The pgAdmin 9.10 release notes, dated 13 November 2025, list this CVE as fixed: "Fixed remote code execution vulnerability when restoring PLAIN-format SQL dumps in server mode (CVE-2025-12762)." The same release notes also list fixes for three other pgAdmin security issues, CVE-2025-12763, CVE-2025-12764 and CVE-2025-12765, covering command injection on Windows and the LDAP authentication flow. If you upgrade for one, you get all four.
The vector is CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L. It is network reachable and needs a low-privilege account, with the scope marked as changed because the impact reaches beyond pgAdmin itself.
How to check if you're exposed
- Find your pgAdmin deployments. Server mode means the web application that several users sign in to, often a container or a package on a shared host.
- Read the version in the About dialog, or from your package manager or container tag. Anything up to 9.9 is in range.
- For a container, check the image tag:
docker ps
docker images | grep -i pgadmin
- Decide who can use the restore feature, and whether anyone who should not have it can sign in.
The free in-browser scan can read a repository or container reference for pgAdmin related packages, and the Gold page for CVE-2025-12762 tracks the record.
What to do now
- Upgrade pgAdmin 4 to 9.10 or later. This is the version named in the release notes.
- Redeploy containers from a fresh 9.10 or newer image rather than patching in place.
- Until then, limit who can sign in to server mode pgAdmin and who can use the restore function. Put the service behind a VPN or an allowlist.
- Review which accounts exist in pgAdmin, and remove stale ones. Check that multi factor authentication is on where you use it.
- Treat restore files like code. Only restore dumps from sources you trust.
- Check the host running pgAdmin for unexpected processes, files or outbound connections, since the flaw can run commands on the server.
Try it yourself
Click through it at your own pace, or open it full screen.
Why it matters
A PLAIN-format dump is a text file of SQL statements. The psql client that usually replays it also understands meta commands, which are instructions to the client itself rather than SQL for the database. Per the upstream issue title, the fix is to block the restore if the PLAIN SQL file contains any meta commands. That tells you the class of problem: the restore path let content in the file reach the host where pgAdmin runs.
The record classifies the flaw as CWE-94, code injection. A database admin tool holds credentials for many databases, so a compromise of the pgAdmin host can reach well beyond one server. The record does not flag CVE-2025-12762 as a CISA Known Exploited Vulnerability and does not claim exploitation in the wild.
Quick check
Which pgAdmin versions are affected, and which is fixed?
Versions up to 9.9 in server mode are affected per the record. The 9.10 release notes list the fix.
Am I affected if I use pgAdmin as a desktop app?
The record describes server mode. Upgrade anyway, since the same release fixes other security issues.
Sources
- pgAdmin issue 9320: block restores containing meta-commands
- pgAdmin 9.10 release notes
- Gold entry for CVE-2025-12762
Last reviewed: 19 October 2026.