CVE-2023-51375 is a medium severity (CVSS 4.3) missing authorization flaw in the EmbedPress WordPress plugin, versions through 3.8.3. A Subscriber account is enough to reach it. Patchstack says to update to version 3.8.4 or later, and suggests asking your host or developer for help if you cannot update.
What's affected
Patchstack's advisory lists the EmbedPress WordPress plugin as affected in the range 3.8.3 and earlier. The record describes a missing authorization vulnerability in EmbedPress.
Patchstack gives 3.8.4 as the fixed version and says to update to 3.8.4 or later. Patchstack says the attacker needs a Subscriber account.
CVSS for this entry is 4.3 (Medium) with vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N.
How to check if you're exposed
On a WordPress site with WP-CLI installed, list the plugin and its version.
wp plugin list --name=embedpress --fields=name,status,version,update_version
If the version is lower than 3.8.4, the site is in the affected range. You can also read the version on the Plugins page of the WordPress dashboard. For many sites, run the command on each one or use your management console.
What to do now
- Check the installed version of EmbedPress on every site you run.
- Update to 3.8.4 or later from the Plugins page, or with wp plugin update embedpress.
- Test the site after the update, especially the features that rely on the plugin.
- If the plugin is no longer needed, deactivate and delete it rather than leaving it installed.
- Review the users on the site and remove accounts you do not recognize, since several plugin flaws depend on a low privilege account.
- Run the free in-browser dependency scan at gold.safeguard.sh/scan against your manifests, and look the entry up in the Safeguard Gold directory to see how it is tracked.
Why it matters
CWE-862 is missing authorization. The code performs an action without checking whether the caller is allowed to. The fix is a capability or role check on every action that changes or reveals data.
CWE-862 is missing authorization. A function does not check whether the caller may use it. The NVD vector needs a low privilege account and shows a low integrity impact only.
The score is modest. Even so, flaws that Subscriber accounts can reach deserve attention on sites with open registration, and updating is the entire fix.
The record does not mark this CVE as listed in the CISA Known Exploited Vulnerabilities catalog, and no source I read reports exploitation in the wild.
Quick check
Is this a high risk?
The score is 4.3 (medium). Risk depends on whether your site lets visitors register.
What is the fix?
Update to 3.8.4 or later.
Sources
Last reviewed: 19 October 2026.