CVE-2023-51359 is a medium severity (CVSS 5.4) missing authorization flaw in the Essential Blocks for Gutenberg WordPress plugin, versions through 4.2.0. A Contributor account is enough to reach it. Patchstack says to update to version 4.2.1 or later, and notes a second related entry for the same plugin.
What's affected
Patchstack's advisory lists the Essential Blocks for Gutenberg WordPress plugin as affected in the range 4.2.0 and earlier. The record describes a missing authorization issue that allows exploiting incorrectly configured access control security levels. It is one of two related entries for the same plugin, the other being CVE-2023-51360.
Patchstack gives 4.2.1 as the fixed version and says to update to 4.2.1 or later. Patchstack says the attacker needs a Contributor account.
CVSS for this entry is 5.4 (Medium) with vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L.
How to check if you're exposed
On a WordPress site with WP-CLI installed, list the plugin and its version.
wp plugin list --name=essential-blocks --fields=name,status,version,update_version
If the version is lower than 4.2.1, the site is in the affected range. You can also read the version on the Plugins page of the WordPress dashboard. For many sites, run the command on each one or use your management console.
What to do now
- Check the installed version of Essential Blocks for Gutenberg on every site you run.
- Update to 4.2.1 or later from the Plugins page, or with wp plugin update essential-blocks.
- Test the site after the update, especially the features that rely on the plugin.
- If the plugin is no longer needed, deactivate and delete it rather than leaving it installed.
- Review the users on the site and remove accounts you do not recognize, since several plugin flaws depend on a low privilege account.
- Run the free in-browser dependency scan at gold.safeguard.sh/scan against your manifests, and look the entry up in the Safeguard Gold directory to see how it is tracked.
Why it matters
CWE-862 is missing authorization. The code performs an action without checking whether the caller is allowed to. The fix is a capability or role check on every action that changes or reveals data.
CWE-862 is missing authorization. The plugin does not check a capability before doing something. The NVD vector needs a low privilege account and shows low integrity and availability impact.
Contributor accounts are common on blogs with several authors, so check who holds them. Updating closes the gap whether or not you trust your contributors.
The record does not mark this CVE as listed in the CISA Known Exploited Vulnerabilities catalog, and no source I read reports exploitation in the wild.
Quick check
How does this differ from CVE-2023-51360?
Same plugin and versions, but this one needs a Contributor account and the other needs only a Subscriber account, per Patchstack.
What is the fix?
Version 4.2.1 or later.
Sources
Last reviewed: 19 October 2026.