CVE-2023-51353 is a medium severity (CVSS 5.3) missing authorization flaw in the Popup by Supsystic WordPress plugin, versions through 1.10.19. Patchstack says to update to version 1.10.20 or later. No login is needed to reach the flaw, so update soon.
What's affected
Patchstack's advisory lists the Popup by Supsystic WordPress plugin as affected in the range 1.10.19 and earlier. The record describes a broken access control issue that allows exploiting incorrectly configured access control security levels.
Patchstack gives 1.10.20 as the fixed version and says to update to 1.10.20 or later. No authentication is required, according to Patchstack.
CVSS for this entry is 5.3 (Medium) with vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N.
How to check if you're exposed
On a WordPress site with WP-CLI installed, list the plugin and its version.
wp plugin list --name=popup-by-supsystic --fields=name,status,version,update_version
If the version is lower than 1.10.20, the site is in the affected range. You can also read the version on the Plugins page of the WordPress dashboard. For many sites, run the command on each one or use your management console.
What to do now
- Check the installed version of Popup by Supsystic on every site you run.
- Update to 1.10.20 or later from the Plugins page, or with wp plugin update popup-by-supsystic.
- Test the site after the update, especially the features that rely on the plugin.
- If the plugin is no longer needed, deactivate and delete it rather than leaving it installed.
- Review the users on the site and remove accounts you do not recognize, since several plugin flaws depend on a low privilege account.
- Run the free in-browser dependency scan at gold.safeguard.sh/scan against your manifests, and look the entry up in the Safeguard Gold directory to see how it is tracked.
Why it matters
CWE-862 is missing authorization. The code performs an action without checking whether the caller is allowed to. The fix is a capability or role check on every action that changes or reveals data.
CWE-862 is missing authorization. The code performs an action without checking whether the caller is allowed to. The NVD vector shows network access, no privileges, and a low integrity impact only, which explains the medium score.
Patchstack rates the priority medium. The reasonable posture is to treat it as routine patching, with extra urgency on sites where popups can carry marketing or legal text that you would not want altered.
The record does not mark this CVE as listed in the CISA Known Exploited Vulnerabilities catalog, and no source I read reports exploitation in the wild.
Try it yourself
Click through it at your own pace, or open it full screen.
Quick check
Do attackers need an account?
No. Patchstack says no authentication is required.
What fixes it?
Version 1.10.20 or later, per Patchstack.
Sources
Last reviewed: 19 October 2026.