CVE-2023-50231 is a stored cross site scripting flaw in the NETGEAR ProSAFE Network Management System, NMS300. NVD scores it 9.6 Critical, while NETGEAR and ZDI score it 8.0 High. The vendor says the issue is fixed in NMS300 version 1.7.0.31, so upgrade to that or later.
What's affected
Product: NETGEAR ProSAFE Network Management System (NMS300). Fixed: version 1.7.0.31, per NETGEAR security advisory PSV-2023-0106. NETGEAR first published its advisory on 19 December 2023, and ZDI released ZDI-23-1847 on 20 December 2023. NVD published the record on 3 May 2024.
The sources disagree on severity, so here are both. The NVD record scores it 9.6 Critical with vector AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H, which is scope changed and no privileges needed. NETGEAR's advisory and ZDI both give 8.0 High, with vector AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H, which needs a low privilege account and keeps scope unchanged. The title uses Critical because that is what the record says. For triage, take the higher figure as a ceiling and the lower as the vendor view.
How to check if you're exposed
NMS300 shows its version in the web console. Compare it with 1.7.0.31.
If you cannot find the version in the console, NETGEAR's advisory describes where to get the current download and release notes from the NETGEAR support site, under the product's Downloads section. Open the release notes of the latest software version and follow the install instructions there.
Also list who has accounts on the management system and which networks can reach its web interface. Stored cross site scripting depends on someone viewing the injected content, so the people with access matter as much as the version.
Like other vendor appliances and server products, NMS300 will not appear in a dependency scan. Keep it in your asset inventory with a version and an owner.
What to do now
- Download the latest NMS300 software from the NETGEAR support site and install version 1.7.0.31 or later, following the release notes.
- Limit access to the management web interface to administrator workstations or a management network.
- Review the node labels and other free text fields in the console for entries you do not recognize.
- Log out of the console when it is not in use, and avoid browsing other sites in the same session.
- Record the new version in your asset inventory.
Why it matters
The weakness is CWE-79, cross site scripting. ZDI says the flaw is in the saveNodeLabel method, where user supplied data is not validated, which lets an attacker inject an arbitrary script. The result is stored, meaning the script is saved by the application and runs later in the browser of whoever views the page.
On a network management console that matters more than on an ordinary website. The viewer is typically an administrator with control over switches and other infrastructure, and the script runs with that person's rights inside the console. That is why the record describes the result as privilege escalation and why the NVD scoring marks scope as changed.
The KEV flag is false and I found no claim of exploitation. The practical lesson is to treat the management plane as sensitive: separate network, limited accounts, prompt updates. The Gold directory lists this CVE with its weakness class, and gold.safeguard.sh/scan covers the open source packages in your own applications.
Quick check
Why do the scores differ?
NVD marks no privileges required and a changed scope, which gives 9.6. NETGEAR and ZDI mark low privileges required and an unchanged scope, which gives 8.0. Both agree on the flaw and the fix.
What is the fixed version?
NMS300 1.7.0.31, according to NETGEAR advisory PSV-2023-0106.
Sources
Last reviewed: 19 October 2026.