Safeguard
Vulnerability Analysis•

CVE-2026-91929: High Flowise Enterprise Cross-Tenant Authorization Gaps

CVE-2026-91929: Flowise before 3.1.4 skips ownership checks in Enterprise endpoints, letting one tenant touch another's workspaces. Upgrade to 3.1.4.

Safeguard Security Team
3 min read

CVE-2026-91929 is a set of cross-tenant authorization gaps in the Enterprise endpoints of Flowise before 3.1.4. NVD rates it High (7.1). A user with Enterprise access can act on workspaces, organizations and roles that belong to someone else. The fix is Flowise 3.1.4.

What's affected

The GitHub advisory lists npm flowise up to and including 3.1.3 as affected and 3.1.4 as patched. The NVD record says versions before 3.1.4. Only deployments that use the paid Enterprise features (workspaces, organizations, roles and login methods) reach the vulnerable code, because the advisory says each endpoint sits behind a plan or Enterprise platform check.

The weakness is CWE-862, missing authorization. The vector is CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L: network reachable, a login required, and high impact on confidentiality and integrity.

On severity, the NVD record says 7.1 High. VulnCheck shows a CVSS v4 score of 7.6 and also calls it high, so the sources are close here. One caveat from the advisory: the reporter said they could not run the endpoints to completion on an unlicensed instance, so the finding rests on source review and was passed to maintainers to confirm.

How to check if you're exposed

Work out whether you use Enterprise features at all. If you run the open source build with no workspaces or organizations enabled, the affected endpoints are not part of your setup. If you do, check the version:

npm ls flowise

For container deployments, compare the image tag with 3.1.4. Review your audit trail for workspace deletions, unexpected invitations and role changes that nobody on your side made. The advisory describes those as the possible effects: deleting workspaces, inviting oneself into another organization, changing roles across organizations, and abusing stored single sign-on secrets.

Paste a lockfile or SBOM into the free in-browser dependency scan to see whether this package is in your tree, including as a transitive dependency. Safeguard's reachability analysis can then show whether your code actually calls the affected path, which helps you order the work.

What to do now

  1. Upgrade Flowise to 3.1.4 or later.
  2. Review workspace, invitation and role history for changes you cannot explain.
  3. If you store SSO configuration in Flowise, consider rotating those secrets after upgrading, since the advisory says stored secrets could be abused.
  4. Limit which accounts hold workspace delete and role management permissions until the upgrade is done.

Why it matters

Multi-tenant software has one job that matters more than any other: a user in one tenant must not be able to name an object in another tenant and have the server act on it. The advisory shows several endpoints that look up a workspace, organization or role by an ID from the request and check that it exists, but never check that it belongs to the caller.

That is why the impact is high on integrity even though the attacker needs a login. A low-privilege account in any tenant becomes a way into all of them. The KEV flag in the record is false and the sources do not report exploitation in the wild.

Quick check

Does this affect the free community edition?

The advisory ties the vulnerable endpoints to Enterprise plan checks, so deployments without those features are not the target. Confirm against your own configuration.

What is the quickest mitigation?

Upgrade to 3.1.4. The sources do not describe a configuration workaround.

Sources

Last reviewed: 18 October 2026.

Never miss an update

Weekly insights on software supply chain security, delivered to your inbox.

Self-healing security runs on Safeguard.

Your first fix PR is minutes away.

No sales call required, even your agent can complete the purchase over MCP.