CVE-2025-24799 is a high severity SQL injection (CVSS 7.5) in GLPI, the open source IT asset management software, reachable by an unauthenticated user through the inventory endpoint. It is fixed in GLPI 10.0.18. Upgrade, and restrict who can reach the inventory endpoint in the meantime.
What's affected
The NVD record names GLPI from the glpi-project vendor. The advisory title reads Unauthenticated SQL injection through the inventory endpoint, and the record says it is fixed in 10.0.18. Versions before 10.0.18 are the range to treat as affected, and the advisory is the place to confirm the exact lower bound.
The vector shows network access, low complexity, no privileges and no interaction, with high impact on confidentiality only. That fits a read focused injection: the likely worry is exposure of data stored in the GLPI database, such as assets, users and configuration details.
The record is not on the CISA Known Exploited Vulnerabilities list.
The weakness is classed as CWE-89 (SQL injection). The score is 7.5 (HIGH). The vector, CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N, reads as reachable over the network, low attack complexity, no privileges required and no user interaction. Impact is high on confidentiality, no on integrity and no on availability. The record was published on 2025-03-18.
GLPI 10.0.18 is the fixed version named in the record and the advisory. Upgrade to it or a later release, following the project's upgrade guide and taking a database backup first.
How to check if you're exposed
GLPI shows its version in the interface, and you can check from the server too.
- Sign in as an administrator and read the version shown in the page footer or in the system information screen.
- If it is below 10.0.18, you are affected.
- On the server, compare the version shown in the interface with the package or release archive you deployed.
- Check whether the inventory endpoint, used by agents to send asset data, is reachable from the internet. If the agents sit on internal networks only, close external access to it.
- Review web server logs for unusual requests to the inventory path.
What to do now
- Back up the GLPI database and files, then upgrade to GLPI 10.0.18 or later.
- Limit access to the inventory endpoint to the networks where your agents live, using the web server or a firewall.
- Review logs for odd requests to the inventory endpoint, especially from addresses you do not recognise.
- If you suspect exposure, change integration tokens and review accounts that have sensitive access.
- Check your other GLPI instances, such as test servers and old copies, for the same version.
Why it matters
SQL injection, listed as CWE-89, appears when input is placed inside a query as text and not passed as a bound value. The database then reads the input as part of the command. It is one of the oldest classes of flaw, and fixes are well known: parameterized queries and strict handling of input.
What raises the stakes here is the combination of an endpoint that must be reachable by agents and no login in front of it. Inventory endpoints are built for machines to post data, so they are often published more widely than the human interface. Asset management systems also hold a map of your estate. That is useful to defenders, and equally useful to someone planning an attack.
If you track many applications, the free in-browser dependency scan at gold.safeguard.sh/scan can show which of your components have known CVEs, and the Gold directory lists each one with its fix status.
Try it yourself
Click through it at your own pace, or open it full screen.
Quick check
Which GLPI version fixes CVE-2025-24799?
GLPI 10.0.18, according to the record and the advisory. Use that or later.
Does an attacker need a GLPI account?
No. The advisory title says unauthenticated, and the vector lists no privileges required.
Sources
- Safeguard Gold entry for CVE-2025-24799
- NVD record data for CVE-2025-24799 (published 2025-03-18)
- GLPI security advisory GHSA-jv89-g7f7-jwfg
Last reviewed: 19 October 2026.