CVE-2023-47132 is a critical flaw in N-able N-central, scored 9.8, that lets attackers gain escalated privileges through API calls. The record says versions before 2023.6 are affected. Upgrade to 2023.6 or later, and read the vendor advisory for the exact fixed builds and any extra steps.
What's affected
The NVD record describes the flaw as an issue in N-able N-central before 2023.6 and earlier that allows attackers to gain escalated privileges through API calls. That phrasing is odd, since before 2023.6 and earlier cannot both be literal. I read it as 2023.6 being the first fixed release, but N-able's advisory is the authority.
The advisory is listed as a reference, but my fetch returned only a loading page, so I could not confirm affected builds, hotfix numbers or any mitigations from the vendor text. Do not rely on this post alone for version decisions.
The score is a network vector with no privileges or user interaction and high impact on confidentiality, integrity and availability. N-central is a remote monitoring and management platform, so the systems it controls are part of the exposure.
The NVD record was published on 2024-02-08, scores 9.8 (Critical), and carries the vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H. Weakness class: CWE-269.
How to check if you're exposed
Find your N-central version and compare it with the version named in the vendor advisory.
- Sign in to the N-central console as an administrator and open the About or system information page to read the version.
- Note whether your server is reachable from the internet, and which API users and tokens exist.
- Review API access logs and the list of users with elevated roles for entries you do not recognize.
If you are on a version earlier than 2023.6, plan the upgrade now and treat unexplained role changes as an incident.
What to do now
- Read the N-able advisory and record the fixed version for your release line.
- Upgrade N-central to 2023.6 or later.
- Restrict access to the server and its API to the networks and people that need it.
- Review users, roles and API tokens, and remove anything unneeded.
- Watch for new advisories, since management platforms are frequent targets.
Why it matters
Escalation through an API is an improper privilege management problem, CWE-269. The service lets a caller do something their role should not allow.
The reach is what raises the score. A management server holds credentials and control over many managed devices. Anyone who gains administrator rights on it can influence all of them. The record's KEV flag is false, so this CVE is not on the CISA Known Exploited Vulnerabilities list.
Keep management planes off the open internet where you can, and treat their patches as urgent.
Try it yourself
Click through it at your own pace, or open it full screen.
Quick check
Is N-central 2023.6 the fix?
The record says versions before 2023.6 are affected. Confirm exact fixed builds in the N-able advisory, which I could not read.
Sources
Last reviewed: 19 October 2026.